Email to Print Not Functioning

Incident Report for SNC ITS

Resolved

We have resolved the issue with the printthis@snc.edu email to print function. Some print jobs may need to be resubmitted but this is working as intended now.
Posted Sep 18, 2026 - 10:14 CDT

Investigating

We are aware of an issue with the printthis@snc.edu email not working for printing documents on campus. We believe that we have found and resolved the issue but are testing and monitoring for now. Printing via web browser at papercut.snc.edu still works and is a good alternative if users are experiencing any issues with the email to print.

We will provide another update after some testing soon.
Posted Sep 18, 2026 - 09:39 CDT
This incident affected: Network (Printing).