Spectrum U Service Outage

Incident Report for SNC ITS

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 09:23 CST

Investigating

We are currently experiencing an issue with our Spectrum U service. We are working with the vendor to resolve the issue.

Accessing Spectrum U from a computer, phone, or other connected device is not functioning, currently.
Posted Dec 08, 2025 - 13:16 CST
This incident affected: Network (SpectrumU).