Instructure appears to have fixed Canvas, and it is currently functioning appropriately.
We're leaving this status page up for awareness.
Posted May 07, 2026 - 22:08 CDT
Update
Canvas is currently experiencing a nationwide outage affecting colleges and universities across the country. ITS is actively monitoring the situation.
Faculty and students are encouraged to communicate via college email regarding assignments, exams, deadlines, and other course-related updates. Students should check email regularly for course communications.
We appreciate your patience and understanding during this disruption and will continue to provide updates as more information becomes available.
Posted May 07, 2026 - 17:40 CDT
Investigating
snc.instructure.com (Canvas) has unexpectedly gone down. We are reaching out and working with Canvas to get this issue resolved as soon as possible.
Posted May 07, 2026 - 15:59 CDT
This incident affected: Educational Technology (Canvas).